분류 전체보기 (121)
Wi-Fi LED Matrix (1)
Code snippets (4)
Music (2)
MacOS & iOS (11)
Linux & Android (22)
Windows & WM (18)
Electronic (20)
Archived (32)
Trash Bin (10)
515,370 Visitors up to today!
Today 29 hit, Yesterday 131 hit
2012.03.20 12:21

#ruby 모듈 중 httparty를 설치하려는데 오류

# sudo gem install httparty

ERROR:  Error installing httparty:
        multi_json requires RubyGems version >= 1.3.6

gems 버전이 낮다는데 help를 봐도 자기 자신을 업데이트 하는 건 없나보다.
구글링 해보니까..

# sudo gem install rubygems-update

Successfully installed rubygems-update-1.8.19
1 gem installed
Installing ri documentation for rubygems-update-1.8.19...
Installing RDoc documentation for rubygems-update-1.8.19...

이런식으로 요놈 -> rubygems-update 을 설치해주고

/var/lib/gems/(특정버전)/bin/update_rubygems

를 실행해주니 업데이트 되더라는...

 

그리고 json 모듈 설치하려니까..

# sudo gem install json

Fetching: json-1.6.5.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing json:
        ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.8 extconf.rb
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
        from extconf.rb:1


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/json-1.6.5 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/json-1.6.5/ext/json/ext/parser/gem_make.out

이런 오류... 아 뭐야 -_-;; 에러가 직관적이지 않아!

결국 sudo apt-get install ruby1.8-dev 로 ruby1.8-dev를 설치해줘서 해결.. -_-ㅋ